University at Buffalo - The State University of New York
Skip to Content

Upgrade Browsers by April 15 to Use SUNY Systems

By Valerie Priester

Published March 23, 2016

As of April 15, 2016, SUNY business systems will only work on updated Web browsers, such as Chrome 33, Firefox 34, and Internet Explorer 11 and higher in order to keep your personal information safe. 

Valerie Priester (UBIT Staff) is a valuable member of UB Information Technology and has worked for UB for over 18 years, most recently as part of the IT Policy & Communication team. When not writing Web content for UBIT, she can be found rowing on Tonawanda Creek, gardening or walking her dog, Maddie.

These browsers incorporate a higher security protocol– TLS 1.1 or TLS 1.2. TLS, or Transport Layer Security, ensures encrypted communication between a server, such as SUNY systems, and a client, such as your Web browser. 

SUNY’s Time and Attendance system, SUNY Finance, SUNY HR and BI Dashboards currently work with any Web browser, but a warning should appear if you are using an incompatible version. As of April 15, 2016, older browsers will no longer be able to access these systems. 

What do I need to do?

Update your Web browser to any of the following by April 15:

  • Chrome 33 and higher
  • Firefox 34 and higher
  • Internet Explorer 11
  • Safari 8 and higher
  • Opera 20 and higher
  • Android 5.1 and higher

Which version is my Web browser?

  • On Windows, within your Web browser, select Help > About.
  • On Macintosh, within the browser, select About from the menu labeled with the name of the browser.

If you need assistance updating your Web browser on a university-owned machine, please contact your departmental IT support or the UBIT Help Center (716-645-3542, www.buffalo.edu/ubit/help).