HUB Essentials

Supported Browsers for HUB Supported Software
Chrome 13 Microsoft Office Excel 2007 & 2010
Internet Explorer 7, 8, 9, & 10 Microsoft Office Word 2007 & 2010
Firefox 7  
Safari 3, 4, 4.3.3, 5 & 6  
Apple iPad 1, 2, 3, & 4  

Internet Explorer Pop-Up Information

If you are using Internet Explorer and you get a security popup window that asks if you want to display both secure and non-secure items, you can prevent that window from appearing again by changing settings as follows:

  • Click Tools
  • Select Internet Options and go to the Security tab
  • To change settings, click Custom Level, scroll down the list and select Enable under Display Mixed Content
  • Next click OK, click Yes on the warning message, and click OK again

If your computer’s operating system is Windows 7, you will see the following warning message on the HUB log in page “We’ve detected that your operating system is not supported by this website. For best results, use one of the following operating systems.” Ignore the warning message and proceed to log in. This message will be removed with an upcoming system update.

Last updated: November 08, 2012 1:30 pm EST